Partial Outage — Communication Services

Incident Report for The Dental App

Resolved

The underlying AWS service incident has been resolved. Messaging and reminder deliveries via Twilio are now fully operational. We continue to monitor for stability.
Posted Oct 20, 2025 - 10:16 EDT

Monitoring

We’re investigating a service degradation affecting messaging features powered by Twilio. This appears related to a broader AWS service disruption impacting connectivity between our systems and Twilio’s API endpoints.

Impact: Some practices may experience delays or failures in outbound text message delivery and appointment reminders.
Posted Oct 20, 2025 - 10:09 EDT