DentalXChange Outage Impacting Claims & Eligibility

Incident Report for The Dental App

Resolved

This incident has been resolved.
Posted Dec 10, 2025 - 11:08 EST

Identified

The clearinghouse TDA integrates with, DentalXChange, is currently experiencing an internet outage at their data center. As a result, all of their APIs are impacted, and the following services are temporarily unavailable:

• Claim submissions from TDA
• Eligibility lookups through TDA

We are actively monitoring the situation and will restore full functionality as soon as connectivity is resolved on their end.

You can track their real-time status here:
https://status.dentalxchange.com/
Posted Dec 10, 2025 - 09:43 EST
This incident affected: API Service.